[2.0.0 Beta 1] [Linux] Insecure mode and cursor lock in a invisible box

Discussion in 'Bug Reports' started by PiratulPamPam, Nov 22, 2015.

  1. I try to connect on a server and the error is giving me is "You are in insecure mode. You must restart before you can connect to secure servers." And i dont know way but i cant move my cursor i can't move my cursor in the game window for too far before will snap back to the middle of the game window
     
  2. Thirteen

    Thirteen Well-Known Member

    This is because Linux binaries aren't working client side. The servers work fine, the client still needs some work it seems.
    I've been talking to someone at valve and hopefully we'll get it fixed soon... (hopefully).
     
  3. Floober

    Floober Noob

    I've found a fix for the mouse problem, if you can manage to spam mouse 1 and hit the little wrench inside the options button you open the source settings which are completly inside the mouse's restraining box, from there go to multiplayer, advanced and turn on the dev console, then open the console with "~" default and type "cl_software_cursor 0" and that should free the cursor.
    However if you open a local server (with the + button on the menu) connecting issues are just the beginning¬†[​IMG]

    I have TF2 installed and all the props and models load correctly but the mod is probably looking in the wrong place for textures. So yeah if they are doing linux support more things to fix.
     
  4. Thirteen

    Thirteen Well-Known Member

    @Floober there's another post about this, Please keep one bug per thread.
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice