Mac and Linux Wineskin guide. (Sorta…)

Discussion in 'Other' started by Agameofscones, Jun 29, 2015.

  1. If you haven't seen it already on the main FP thread, here it is in all of it's madness, raw from FP.

    Greetings comrades, I bring hope to the land of Mac and Linux with my latest exploits within Wine! What was originally "Hey, that Terraria update is coming out soon, I should set up a Steam wineskin so I can grab it" turned into "Maybe TF2C will work?". Maybe indeed, and the answer is: Yes, with some downsides.

    Why did I do this? I did it to circumvent the failed to load library client error and install Terraria on the side.


    As you can already see we've got some text drawing issues. This is most likely caused by the fact that I have the dwrite library disabled for the entire Wineskin I'm using instead of just Steam. I'll check that out later. Besides that it's quite functional and runs like a charm (Surprisingly). The only thing that I discovered was that Fourt was more poorly optimized than I originally thought, but it was manageable on my 2009 Macbook. Still potatoes like mine will barely run the map until I slap some area portals and hints onto it. I also forgot to pack some textures and left out a section of the Red team base. Minor stuff that can be fixed. Shout out to SPUF.CO for hosting my map! It means a lot, at least to me.
    So Gordon, about that resolution I owed ya…


    Since I know you're wondering how I did it, I used this handy dandy tutorial for installing the Windows copy of Steam on Mac. Hopefully these instructions translate over to Linux users!
    <font size="3">If Winetricks errors on you, you can always grab the setup exe for Steam from the official download page. It's found as a hyperlink in the text that goes along the lines of "Steam is also available for Windows and Linux". After you've got it just hit the install software button and locate the exe.</font>

    The next thing I did was use this little tid bit to fix the invisible text.

    (I did this because Winetricks failed to install Steam. If it doesn't you can skip this portion assuming you have Winetricks updated.)


    After that I logged in and verified this 'new' computer.
    Next I followed this Terraria install guide. The only portion that seems relevant to the source engine is the installing of the Microsoft Service Pack and the .Net framework. Correct me if I'm wrong.
    (Please note, it doesn't matter if you have setup Steam already. Also, can't help you if it errors out on this part, as it worked fine for me.)
    Post Service pack and .Net I ran Terraria, got the XNA framework and had fun there. As far as I know I don't think Source needs the XNA framework to run.

    I installed the Source SDK Base 2013 and set it to upcoming. (Make sure to run it at least once before continuing!)
    I then put the TF2C folder in the sourcemods folder found in the virtual drive. (You can get the path by using the show local content button and copying the path or mimicking it from the Wine Explorer window that appears.)
    I restarted the wrapper and booted up normally, connected to SPUF.CO and discovered that my map runs like shit.

    The only downside to running TF2C via Wineskin is that A. It's very resource intensive, but if my macbook can handle it, maybe yours can too. And B. Wineskin takes up some extra space with its libraries and whatnot, not to mention can be buggy as all hell.

    Have fun you magnificent bastards.

    tl;dr My map is kinda broken but TF2C runs well under a Wineskin (With some text issues). Installation guide above.
  2. PartyDude

    PartyDude Noob

    Mac is cancer, get a PC
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice